PDF's not downloading
Incident Report for Ninety One Investment Platform
Resolved
This incident has been resolved.
Posted Sep 12, 2024 - 16:15 SAST
Investigating
We are aware that PDF documents are not currently downloading and are investigating the issue.
Posted Sep 12, 2024 - 15:58 SAST
This incident affected: Transacting and Reporting.