Ninety One IP Transactional website - intermittent errors across functionality

Incident Report for Ninety One Investment Platform

Resolved

This incident has been resolved.
Posted Sep 08, 2025 - 12:12 SAST

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Sep 08, 2025 - 10:59 SAST

Identified

The issue has been identified and a fix is being implemented.
Posted Sep 08, 2025 - 10:28 SAST

Update

We are continuing to investigate this issue.
Posted Sep 08, 2025 - 08:47 SAST

Investigating

There is currently an issue on our Ninety One IP transactional website. We are investigating and apologise for the inconvenience.
Posted Sep 08, 2025 - 08:44 SAST
This incident affected: Login, Transacting, Reporting, and Market data tools.